Search This Blog

Tuesday, January 22, 2019

SQL Server Native Client version warning in the SCCM prerequisite check

When running the prerequisite check before upgrading SCCM to the newest releases you might see the following warning (this is taken from 1812):

image

Warning details:

SQL Server Native Client version

[Completed with warning]:Verifies that the version of Microsoft SQL Server Native Client installed on the site server meets the minimum requirements to enable TLS 1.2 support. https://go.microsoft.com/fwlink/?linkid=2026746

We can ignore the prerequisite check warning, but if we want to support TLS 1.2 now or later, then upgrade the SQL Native Client.

Use Control Panel - Programs and Features to identify the currently installed version:

image

In this case Microsoft SQL Server 2012 Native Client is installed and we can find the latest version available in this link:

https://support.microsoft.com/en-us/help/3135244/tls-1-2-support-for-microsoft-sql-server

image

Our download link will then be:

https://www.microsoft.com/en-us/download/details.aspx?id=50402

image

You can also see the current version by launching ODBC Data Sources (64-bit):

image

image

Download the update and start the installer, the installer should inform us about a lower version detected, select YES to continue:

image

image

image

image

image

image

image

After the restart you can see the new version installed in the control Panel or in the ODBC Data source:

image

image

We are now ready to run the prerequisite check again.

No comments:

Post a Comment